Не отправляет войска

Сложности в работе после запуска. Сообщайте о найденных недочетах в работе Травиан Бота
Pazuzu
Сообщения: 16
Зарегистрирован: 10 июн 2013, 20:57

Re: Не отправляет войска

Сообщение Pazuzu » 20 фев 2014, 20:08

Vlad писал(а):Сделал временно "костыль" с переключением деревни для ру2

дык сегодня же что-то на ру2 починяли с 2 до 3 часов по москве... или костыль для "починеной травы"? :D
Vlad
Разработчик
Сообщения: 2758
Зарегистрирован: 16 авг 2010, 21:21

Re: Не отправляет войска

Сообщение Vlad » 21 фев 2014, 10:53

Ну я не в курсе починяли или нет, если листы начали разворачиваться, напишите, уберу
semennov
Сообщения: 26
Зарегистрирован: 05 фев 2014, 14:39

Re: Не отправляет войска

Сообщение semennov » 22 фев 2014, 15:38

при отправке войск используя список избранных целей бот из одной деревни отправляет просто по целям бота без голд клуба, а из другой вообще не отправляет.
если убираешь галочку автоматической отправки с одной деревни, то из другой все отправляет...
кеш бота и браузера чистил.
что делать?
Vlad
Разработчик
Сообщения: 2758
Зарегистрирован: 16 авг 2010, 21:21

Re: Не отправляет войска

Сообщение Vlad » 24 фев 2014, 09:45

Что в логе бота?
Sol
Сообщения: 11
Зарегистрирован: 22 ноя 2012, 10:46

Re: Не отправляет войска

Сообщение Sol » 24 фев 2014, 21:13

Зависает при отправке спама из плана атак. Вот последний из логов:
    24.02.2014 3:01:50: Произошло исключение!
    24.02.2014 3:01:50: Type: EAccessViolation App version: 3.5.7.0
    24.02.2014 3:01:50: Message: Access violation at address 00405292 in module 'UnitSenderT4.exe'. Read of address 00000020
    24.02.2014 3:01:50: ------------------------------------------------------------------------ Call Stack ------------------------------------------------------------------------
    24.02.2014 3:01:50: > [00405292] System.@LStrCmp
    24.02.2014 3:01:50: > [0040448F] System.@HandleAnyException
    24.02.2014 3:01:50: > [00714330] Main.TMainThread.DoMsg (Line 23790, "Source\Main.pas")
    24.02.2014 3:01:50: > [00407EC0] Windows.GetCurrentThreadId
    24.02.2014 3:01:51: > [00410F60] SysUtils.TThreadLocalCounter2.HashIndex (Line 12816, "SysUtils.pas")
    24.02.2014 3:01:51: > [00407EC0] Windows.GetCurrentThreadId
    24.02.2014 3:01:51: > [0041102F] SysUtils.TThreadLocalCounter2.Recycle (Line 12874, "SysUtils.pas")
    24.02.2014 3:01:51: > [00410FAA] SysUtils.TThreadLocalCounter2.Open (Line 12835, "SysUtils.pas")
    24.02.2014 3:01:51: > [0040AACB] SysUtils.StrToInt (Line 4071, "SysUtils.pas")
    24.02.2014 3:01:51: > [00422A8D] Classes.TStringList.Get
    24.02.2014 3:01:51: > [007283B3] Main.TEventQueue.DeleteEvent (Line 27950, "Source\Main.pas")
    24.02.2014 3:01:51: ------------------------------------------------------------------------------------------------------------------------------------------------------------
    24.02.2014 3:02:09: Произошло исключение!
    24.02.2014 3:02:09: Type: EAccessViolation App version: 3.5.7.0
    24.02.2014 3:02:09: Message: Access violation at address 0072836C in module 'UnitSenderT4.exe'. Read of address 00000008
    24.02.2014 3:02:09: ------------------------------------------------------------------------ Call Stack ------------------------------------------------------------------------
    24.02.2014 3:02:09: > [0072836C] Main.TEventQueue.DeleteEvent (Line 27946, "Source\Main.pas")
    24.02.2014 3:02:09: > [0040448F] System.@HandleAnyException
    24.02.2014 3:02:09: > [00537BA7] DBGridEh.TCustomDBGridEh.CanEditShow (Line 7350, "DBGridEh.pas")
    24.02.2014 3:02:09: > [00468ACB] Controls.TWinControl.WndProc (Line 6242, "Controls.pas")
    24.02.2014 3:02:09: > [00547016] DBGridEh.TCustomDBGridEh.WndProc (Line 13572, "DBGridEh.pas")
    24.02.2014 3:02:09: > [00465870] Controls.TControl.Perform (Line 4468, "Controls.pas")
    24.02.2014 3:02:09: > [0046AEA5] Controls.TWinControl.Invalidate (Line 7592, "Controls.pas")
    24.02.2014 3:02:09: > [00538549] DBGridEh.TCustomDBGridEh.DataChanged (Line 7547, "DBGridEh.pas")
    24.02.2014 3:02:09: > [00531C70] DBGridEh.TGridDataLinkEh.DataSetChanged (Line 4152, "DBGridEh.pas")
    24.02.2014 3:02:09: > [0050D01E] DB.TDataLink.DataEvent (Line 7309, "DB.pas")
    24.02.2014 3:02:09: > [0050D58C] DB.TDataSource.NotifyLinkTypes (Line 7579, "DB.pas")
    24.02.2014 3:02:09: ------------------------------------------------------------------------------------------------------------------------------------------------------------

п.с. разница по времени между отправка меньше 3 минут, может быть из-за этого?
Vlad
Разработчик
Сообщения: 2758
Зарегистрирован: 16 авг 2010, 21:21

Re: Не отправляет войска

Сообщение Vlad » 25 фев 2014, 10:04

Из-за разницы во времени, нет
Попробуйте поменять браузер на вкладке профиль
mihailkv
Сообщения: 2
Зарегистрирован: 23 апр 2014, 14:44

Re: Не отправляет войска

Сообщение mihailkv » 23 апр 2014, 14:47

Только что купил бот. Ставлю фарм бота на списки голдклуба. После тыкаю галку отправлять по спискам. Фарм не уходит. Заданный интервал времени 10 минут (ставил 40). Списков 4 штуки. Все проверил: фарм с одной деры, везде интервалы, но войска не уходят. Играю на http://ts2.travian.ru/. Подскажите в чем проблема?
ПС. В поле "Последняя отправка" везде стоит дата: 30.12.1899. Что это значит?
Vlad
Разработчик
Сообщения: 2758
Зарегистрирован: 16 авг 2010, 21:21

Re: Не отправляет войска

Сообщение Vlad » 24 апр 2014, 09:20

Галку отправлять выбранные списке скорее всего не поставили
А вообще
http://wiki.travibot.com/Farm
mihailkv
Сообщения: 2
Зарегистрирован: 23 апр 2014, 14:44

Re: Не отправляет войска

Сообщение mihailkv » 28 апр 2014, 14:03

Разобрался. Бот читал отчеты примерно часа 3 прежде чем начать отправлять.

Вернуться в «Технические проблемы»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость