Проблема

Сложности в работе после запуска. Сообщайте о найденных недочетах в работе Травиан Бота
U571
Сообщения: 27
Зарегистрирован: 02 апр 2012, 10:29

Проблема

Сообщение U571 » 04 апр 2012, 00:59

Бот страшно тупит и практически не хочет работать
Лог пишет красным
04.04.2012 9:36:18: Начата отправка героя на приключения
04.04.2012 9:37:03: У героя слишком мало здоровья, кажется, он даже умер)
04.04.2012 9:39:50: Произошло исключение!
04.04.2012 9:39:50: Type: EAccessViolation App version: 3.4.1.6
04.04.2012 9:39:50: Message: Access violation at address 00403FAC in module 'UnitSenderT4.exe'. Read of address 00000029
04.04.2012 9:39:50: ------------------------------------------------------------------------ Call Stack ------------------------------------------------------------------------
04.04.2012 9:39:50: > [00403FAC] System.TObject.Free
04.04.2012 9:39:50: > [006B6151] Main.TForm1.FormClose (Line 6914, "..\Source\Main.pas")
04.04.2012 9:39:50: > [00456AC7] Forms.TCustomForm.DoClose (Line 2847, "Forms.pas")
04.04.2012 9:39:50: > [0045A001] Forms.TCustomForm.Close (Line 4590, "Forms.pas")
04.04.2012 9:39:50: > [004592C4] Forms.TCustomForm.WMClose (Line 4157, "Forms.pas")
04.04.2012 9:39:50: > [00465A84] Controls.TControl.WndProc (Line 4561, "Controls.pas")
04.04.2012 9:39:50: > [00468AAF] Controls.TWinControl.WndProc (Line 6242, "Controls.pas")
04.04.2012 9:39:50: > [004ACAC2] ComCtrls.TCustomListView.WndProc (Line 14594, "ComCtrls.pas")
04.04.2012 9:39:50: > [00465854] Controls.TControl.Perform (Line 4468, "Controls.pas")
04.04.2012 9:39:50: > [00468BE7] Controls.DoControlMsg (Line 6288, "Controls.pas")
04.04.2012 9:39:50: > [00469265] Controls.TWinControl.WMNotify (Line 6479, "Controls.pas")
04.04.2012 9:39:50: ------------------------------------------------------------------------------------------------------------------------------------------------------------
04.04.2012 9:39:51: Произошло исключение!
04.04.2012 9:39:51: Type: EAccessViolation App version: 3.4.1.6
04.04.2012 9:39:51: Message: Access violation at address 00403FAC in module 'UnitSenderT4.exe'. Read of address 00000029
04.04.2012 9:39:51: ------------------------------------------------------------------------ Call Stack ------------------------------------------------------------------------
04.04.2012 9:39:51: > [00403FAC] System.TObject.Free
04.04.2012 9:39:51: > [006B6151] Main.TForm1.FormClose (Line 6914, "..\Source\Main.pas")
04.04.2012 9:39:51: > [00456AC7] Forms.TCustomForm.DoClose (Line 2847, "Forms.pas")
04.04.2012 9:39:51: > [0045A001] Forms.TCustomForm.Close (Line 4590, "Forms.pas")
04.04.2012 9:39:51: > [004592C4] Forms.TCustomForm.WMClose (Line 4157, "Forms.pas")
04.04.2012 9:39:51: > [00465A84] Controls.TControl.WndProc (Line 4561, "Controls.pas")
04.04.2012 9:39:51: > [00468AAF] Controls.TWinControl.WndProc (Line 6242, "Controls.pas")
04.04.2012 9:39:51: > [00457291] Forms.TCustomForm.WndProc (Line 3100, "Forms.pas")
04.04.2012 9:39:51: > [00766C22] Main.TForm1.WndProc (Line 32741, "..\Source\Main.pas")
04.04.2012 9:39:51: > [00500FFB] EmbeddedWB.TEmbeddedWB.FormWndProc (Line 1286, "EmbeddedWB.pas")
04.04.2012 9:39:51: > [0046872C] Controls.TWinControl.MainWndProc (Line 6139, "Controls.pas")
04.04.2012 9:39:51: ------------------------------------------------------------------------------------------------------------------------------------------------------------

ну, и тд.
И как с этим бороться?

Windows XP Браузер MSIE установленный в системе. в индефикации пробовал другие поставить но результат такой же.
Vlad
Разработчик
Сообщения: 2769
Зарегистрирован: 16 авг 2010, 21:21

Re: Проблема

Сообщение Vlad » 04 апр 2012, 09:08

viewtopic.php?f=8&t=716

И версию Интернет эксплорера заодно укажите
U571
Сообщения: 27
Зарегистрирован: 02 апр 2012, 10:29

Re: Проблема

Сообщение U571 » 04 апр 2012, 10:02

Блин, как сказали про версию браузера, так я и офигел когда глянул,- IE 6, установил IE 8 и все забегало.
Похоже проблема решена. Спасибо.
Vlad
Разработчик
Сообщения: 2769
Зарегистрирован: 16 авг 2010, 21:21

Re: Проблема

Сообщение Vlad » 04 апр 2012, 10:18

Староват ие6 слегка уже...
U571
Сообщения: 27
Зарегистрирован: 02 апр 2012, 10:29

Re: Проблема

Сообщение U571 » 04 апр 2012, 13:08

Так в том то и дело, я Мозилой 11 пользуюсь, а про IE давно забыл, у меня и по умолчанию Мозила прописана, но Бот почему то упорно не хочет к ней обращаться, тянет все через IE.
Vlad
Разработчик
Сообщения: 2769
Зарегистрирован: 16 авг 2010, 21:21

Re: Проблема

Сообщение Vlad » 04 апр 2012, 14:55

)))
ИЕ единственный браузер, который предоставляет нормальный интерфейс для работы с собой
Что бы вы где ни прописывали, альтернитив просто нет

Вернуться в «Технические проблемы»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость