Auto removal of troops sometimes works and sometimes not

Screat
Posts: 32
Joined: 03 Jul 2018, 16:17

Auto removal of troops sometimes works and sometimes not

Postby Screat » 18 Dec 2019, 08:37

Hey,

just like in the subject - this night I have lost cats, because auto removal of troops didn't work... How is thas possible? In LOG I have info "Attack detected", but nothing was done due to that fact. I only have recieved email, but I was sleeping...

And, again, automatically spending resources (due to "Cannot find NPC link") also doesnt work.

In logs it didnt show anything - it didnt show - only detected attack and did nothing to that. But sometimes it works like a charm...

Any idea?
User avatar
Vlad
Разработчик
Posts: 4101
Joined: 16 Aug 2010, 21:21

Re: Auto removal of troops sometimes works and sometimes not

Postby Vlad » 18 Dec 2019, 10:35

Your game time and PC time is the same?
If no, do you set correctly setting - Menu->Settings->Time on this PC?
Screat
Posts: 32
Joined: 03 Jul 2018, 16:17

Re: Auto removal of troops sometimes works and sometimes not

Postby Screat » 18 Dec 2019, 10:47

I have set this like this:
"Time on PC is" -> "Server time"

and it is correct - by correct, I mean, right now it is 09:47 at my PC, at the server is 09:47 also ;d

Schould I tick "Time synchronization with the server" ?

The weird thing is, most of the time auto removal of troops works, but in ~20% of cases it doesn't. Attack is recognized early enough to make all necessary preparation.

May it be the case, that in the time of removal of troops, bot is sending so many farm, that it 'forgets' to remove troops?
User avatar
Vlad
Разработчик
Posts: 4101
Joined: 16 Aug 2010, 21:21

Re: Auto removal of troops sometimes works and sometimes not

Postby Vlad » 18 Dec 2019, 11:34

No, bot interrupts the farms sending when want to withdraw troops
By description, attack is not detected or auto withdrawal disabled for attacked village, at any other case bot will write "Started auto-withdrawal troops from the village..." in log, even if withdrawal will fail
Screat
Posts: 32
Joined: 03 Jul 2018, 16:17

Re: Auto removal of troops sometimes works and sometimes not

Postby Screat » 18 Dec 2019, 13:17

Okay, but - attack was detected, I have checked it in log. It was detected ~25minutes before attack. So first option - "attack is not detected" fails.

About second option - "auto withdrawal disabled for attacked village" - I have a setting like this:

Image

is that correct?

If yes, what would be the reason of failing auto removal then?:(
User avatar
Vlad
Разработчик
Posts: 4101
Joined: 16 Aug 2010, 21:21

Re: Auto removal of troops sometimes works and sometimes not

Postby Vlad » 18 Dec 2019, 14:10

Correct
No more possible reasons
PS
Check NPC link in 6.0.0.1
Screat
Posts: 32
Joined: 03 Jul 2018, 16:17

Re: Auto removal of troops sometimes works and sometimes not

Postby Screat » 18 Dec 2019, 14:25

Thanks, I will check NPC link asap.

So, if there is no more possible reasons... I will wait, maybe that won't happen again. If this will happen again, can we talk in PM?
User avatar
Vlad
Разработчик
Posts: 4101
Joined: 16 Aug 2010, 21:21

Re: Auto removal of troops sometimes works and sometimes not

Postby Vlad » 18 Dec 2019, 14:47

Yes
Screat
Posts: 32
Joined: 03 Jul 2018, 16:17

Re: Auto removal of troops sometimes works and sometimes not

Postby Screat » 18 Dec 2019, 20:37

Priv:)

Return to “Travian Bot - new versions, bugs, etc (English)”

Who is online

Users browsing this forum: No registered users and 1 guest